Categories Class

The Categories object is a map that contains all the top-level Category objects within the Document.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBCategoryNameMap
      Autodesk.Revit.DBCategories

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Categories : CategoryNameMap

The Categories type exposes the following members.

Properties
 NameDescription
Public propertyIsEmptyWhether or not the list of top-level categories is empty.
(Overrides CategoryNameMapIsEmpty)
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyItemBuiltInCategory Retrieves a category object corresponding to a BuiltInCategory id.
Public propertyItemStringGets a category which has the specified name from this list of top-level categories.
(Overrides CategoryNameMapItemString)
Public propertySizeThe total number of top-level categories in the document.
(Overrides CategoryNameMapSize)
Top
Methods
 NameDescription
Public methodClearRemoves every category from the map, rendering it empty.
(Inherited from CategoryNameMap)
Public methodContainsIdentifies if a category which has the specified name is in the list of top-level categories.
(Overrides CategoryNameMapContains(String))
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodEraseRemoves a category with the specified name from the map.
(Inherited from CategoryNameMap)
Public methodForwardIteratorRetrieves a forward moving iterator to the map.
(Overrides CategoryNameMapForwardIterator)
Public methodGetEnumeratorRetrieves a forward moving iterator to the map.
(Overrides CategoryNameMapGetEnumerator)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodInsertInserts the specified category with the specified name into the map.
(Overrides CategoryNameMapInsert(String, Category))
Public methodCode exampleNewSubcategoryAdd a new subcategory into the Autodesk Revit document.
Public methodReverseIteratorRetrieves a backward moving iterator to the map.
(Overrides CategoryNameMapReverseIterator)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
Use this object to retrieve categories by name or by BuiltInCategory id.
Example
// Get settings of current document
Settings documentSettings = document.Settings;

// Get all categories of current document
Categories groups = documentSettings.Categories;

// Show the number of all the categories to the user
String prompt = "Number of all categories in current Revit document:" + groups.Size;

// get Floor category according to OST_Floors and show its name
Category floorCategory = groups.get_Item(BuiltInCategory.OST_Floors);
prompt += floorCategory.Name;

// Give the user some information
TaskDialog.Show("Revit",prompt);
See Also