CategoriesNewSubcategory Method |
Add a new subcategory into the Autodesk Revit document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Category NewSubcategory(
Category parentCategory,
string name
)
Public Function NewSubcategory (
parentCategory As Category,
name As String
) As Category
public:
Category^ NewSubcategory(
Category^ parentCategory,
String^ name
)
member NewSubcategory :
parentCategory : Category *
name : string -> Category
Parameters
- parentCategory Category
- The parent category.
- name String
- The new category name.
Return Value
CategoryIf successful, the newly created subcategory.
ExceptionsException | Condition |
---|
ArgumentNullException |
Thrown when the input argument-"parentCategory" or "name"-is .
|
ArgumentException |
Thrown when the input argument-"parentCategory"-cannot add subcategory.
Thrown when the input argument-"name"-is an illegal name.
|
InvalidOperationException |
Thrown when subcategory creation failed.
|
Examplepublic void AssignSubCategory(Document document, GenericForm extrusion)
{
Category cat = document.OwnerFamily.FamilyCategory;
Category subCat = document.Settings.Categories.NewSubcategory(cat, "NewSubCat");
ElementId materialId = Material.Create(document, "Wood Material");
subCat.Material = document.GetElement(materialId) as Material;
extrusion.Subcategory = subCat;
}
Public Sub AssignSubCategory(document As Document, extrusion As GenericForm)
Dim cat As Category = document.OwnerFamily.FamilyCategory
Dim subCat As Category = document.Settings.Categories.NewSubcategory(cat, "NewSubCat")
Dim materialId As ElementId = Material.Create(document, "Wood Material")
subCat.Material = TryCast(document.GetElement(materialId), Material)
extrusion.Subcategory = subCat
End Sub
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also