CategoryNameMap Class

A map that contains a mapping of category name to its category object.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBCategoryNameMap
      Autodesk.Revit.DBCategories

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CategoryNameMap : APIObject, 
	IEnumerable

The CategoryNameMap type exposes the following members.

Constructors
 NameDescription
Public methodCategoryNameMapInitializes a new instance of the CategoryNameMap class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the map is empty.
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyItemGets or sets a category at a specified name within the map.
Public propertySizeReturns the number of categories that are in the map.
Top
Methods
 NameDescription
Public methodClearRemoves every category from the map, rendering it empty.
Public methodContainsTests for the existence of a category with that name within the map.
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodEraseRemoves a category with the specified name from the map.
Public methodForwardIteratorRetrieve a forward moving iterator to the map.
Public methodGetEnumeratorRetrieve a forward moving iterator to the map.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodInsertInsert the specified category with the specified name into the map.
Public methodReverseIteratorRetrieve a backward moving iterator to the map.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also