CategoriesItem(BuiltInCategory) Property |
Retrieves a category object corresponding to a BuiltInCategory id.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic virtual Category this[
BuiltInCategory categoryId
] { get; }
Public Overridable ReadOnly Property Item (
categoryId As BuiltInCategory
) As Category
Get
public:
virtual property Category^ Item[BuiltInCategory categoryId] {
Category^ get (BuiltInCategory categoryId);
}
abstract Item : Category with get
override Item : Category with get
Parameters
- categoryId BuiltInCategory
-
Property Value
Category
Remarks Unlike the method that obtains categories by name, this routine will obtain
the handle even of built-in subcategories.
Since 2016 it is advised to use either [!:Autodesk::Revit::DB::Category::GetCategory(Document,BuiltInCategory)]
or [!:Autodesk::Revit::DB::Category::GetCategory(Document,ElementId)] method from Category class.
See Also