CategoriesItem(String) Property |
Gets a category which has the specified name from this list of top-level categories.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic override Category this[
string name
] { get; set; }
Public Overrides Property Item (
name As String
) As Category
Get
Set
public:
virtual property Category^ Item[String^ name] {
Category^ get (String^ name) override;
void set (String^ name, Category^ value) override;
}
abstract Item : Category with get, set
override Item : Category with get, set
Parameters
- name String
- The name of the category to be retrieved.
Property Value
CategoryThe category with the specified name.
ExceptionsException | Condition |
---|
InvalidOperationException | Thrown when the category list does not contain the category with this name.
Thrown when trying to set an item to this list of categories; this list is read only. |
See Also