PrintManager Class

The PrintManager object is used to configure the global print settings.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBPrintManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PrintManager : APIObject

The PrintManager type exposes the following members.

Properties
 NameDescription
Public propertyCollate Indicates whether to collate of the current print.
Public propertyCombinedFile Indicates whether to combine multiple selected views/sheets into a single file.
Public propertyCopyNumber The copy number.
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyIsVirtual The virtual type in Autodesk Revit.
Public propertyPaperSizesGet all print sizes of current printer.
Public propertyPaperSourcesGet all print sources of current printer.
Public propertyPrinterName The name of the current printer.
Public propertyPrintOrderReverse Indicates whether to reverse the print order of the current print.
Public propertyPrintRange The print range.
Public propertyPrintSetup The PrintSetup which manages the print settings of current document.
Public propertyPrintToFile Indicates whether to print to file.
Public propertyPrintToFileName The file name when printing to file.
Public propertyViewSheetSetting The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.
Top
Methods
 NameDescription
Public methodApply Apply the local print settings to global for all documents.
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSelectNewPrintDriver Select a new printer.
Public methodSubmitPrint Print the views and sheets defined in the current local PrintManager settings.
Public methodSubmitPrint(View) Print a view with the current PrintManager settings.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
Global print settings include PrintToFile, CombinedFile, PrintToFileName, PrintRange, CopyNumber, PrintOrderReverse, Collate. Once PrintManager is acquired from a document, changes of its global print setting properties are not automatically applied toward the global print setting. Should the local setting be used, the user needs to call the Apply method. If the user calls SubmitPrint methods, not only that printing will use the current state of properties of the (local) print manager, but the setting will also be applied to the global settings.
Example
private void CreateAndPrintViewSet(Document document, ViewSet viewSet)
{
    PrintManager printManager = document.PrintManager;
    printManager.PrintRange = PrintRange.Select;
    ViewSheetSetting viewSheetSetting = printManager.ViewSheetSetting;
    viewSheetSetting.CurrentViewSheetSet.Views = viewSet;
    viewSheetSetting.SaveAs("MyViewSet");
    printManager.CombinedFile = true;
    printManager.SubmitPrint();
}
See Also