PrintManagerSubmitPrint Method |
Print the views and sheets defined in the current local PrintManager settings.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool SubmitPrint()
Public Function SubmitPrint As Boolean
public:
bool SubmitPrint()
member SubmitPrint : unit -> bool
Return Value
BooleanTrue if successful, otherwise False.
ExceptionsException | Condition |
---|
InvalidOperationException |
Thrown when this operation is not allowed in the current application mode,
or the print resource is occupied by others.
|
Remarks
PrintManager will apply the local settings to global and print the view/views/sheets which user defined with the current settings.
See Also