PrintManagerSubmitPrint(View) Method |
Print a view with the current PrintManager settings.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool SubmitPrint(
View view
)
Public Function SubmitPrint (
view As View
) As Boolean
public:
bool SubmitPrint(
View^ view
)
member SubmitPrint :
view : View -> bool
Parameters
- view View
- The User-assigned view.
Return Value
BooleanTrue if successful, otherwise False.
ExceptionsException | Condition |
---|
InvalidOperationException |
Thrown when this operation is not allowed in the current application mode,
or the print resource is occupied by others.
|
Remarks
PrintManager will apply the local settings to global and print the user-assigned view with the current settings.
See Also