ScheduleField Class

A field in a schedule.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBScheduleField

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ScheduleField : IDisposable

The ScheduleField type exposes the following members.

Properties
 NameDescription
Public propertyColumnHeading The column heading text.
Public propertyDefinition The ScheduleDefinition that this field belongs to.
Public propertyDisplayType Indicates the chosen display type for the field.
Public propertyFieldId The ID of the field in the containing ScheduleDefinition.
Public propertyFieldIndex The index of the field in the containing ScheduleDefinition.
Public propertyFieldType The type of data displayed by the field.
Public propertyGridColumnWidth The width of the column in the editable grid view, measured in feet.
Public propertyHasSchedulableField Identifies if this ScheduleField object has access to a SchedulableField. Calculated and combined parameter fields will not have the access.
Public propertyHeadingOrientation The orientation of the column heading text.
Public propertyHorizontalAlignment The horizontal alignment of the column's data.
Public propertyIsCalculatedField Indicates if the field is a calculated field (Formula or Percentage).
Public propertyIsCombinedParameterField Indicates if the field is a combined parameter field.
Public propertyIsHidden Indicates if the field is hidden in the schedule.
Public propertyIsOverridden Indicates if the field is overridden or not.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyMultipleValuesCustomText The custom multiple values text to be used when the schedule field displays multiple element values, used when MultipleValuesDisplayType is set to Custom.
Public propertyMultipleValuesDisplayType Determines the type of multiple value indication to be used when the schedule field displays multiple element values.
Public propertyMultipleValuesText The multiple values text to be used when the schedule field displays multiple element values, as specified by the display type MultipleValuesDisplayType.
Public propertyParameterId The ID of the parameter displayed by the field.
Public propertyPercentageBy The ID of the grouped schedule field used to calculate percentage totals.
Public propertyPercentageOf The ID of the field to calculate percentages of.
Public propertySchedule The schedule that this field belongs to.
Public propertySheetColumnWidth The width of the column on a sheet, measured in feet.
Public propertyTotalByAssemblyType In an assembly schedule view, indicates if totals are calculated for all assembly instances of the same type or only for a single instance.
Public propertyVerticalAlignment The vertical alignment of the column's data.
Top
Methods
 NameDescription
Public methodCanDisplayMinMax Indicates if this field can display minimum and maximum values.
Public methodCanTotal Indicates if totals can be enabled for this field.
Public methodCanTotalByAssemblyType Indicates if totals by assembly type can be enabled for this field.
Public methodCreatesCircularReferences Checks whether a field ID would create a circular chain of references when used by the PercentageOf property of this field.
Public methodDisposeReleases all resources used by the ScheduleField
Public methodGetCombinedParameters Gets this field's combine parameter array if applicable
Public methodGetCustomFieldData Gets the data associated with this custom field. If this field isn't a CustomField will return .
Public methodGetFormatOptions Gets the FormatOptions to optionally override the default settings in the Units class.
Public methodGetName Gets the name of the field.
Public methodGetSchedulableField Gets a SchedulableField object representing this field.
Public methodGetSpecTypeId The spec describing values of this field, if applicable.
Public methodGetStyle Gets the style of this field.
Public methodIsValidCombinedParameters Checks if data is valid for combined parameters
Public methodResetOverride Resets the override of this field.
Public methodSetCombinedParameters Sets this field's combine parameter array if applicable
Public methodCode exampleSetFormatOptions Sets the FormatOptions to optionally override the default settings in the Units class.
Public methodSetStyle Sets the style of this field.
Top
Remarks

The ScheduleField class represents a single field in a ScheduleDefinition's list of fields. Each (non-hidden) field becomes a column in the schedule.

Most commonly, a field represents an instance or type parameter of elements appearing in the schedule. Some fields represent parameters of other related elements, like the room that a scheduled element belongs to. Fields can also represent data calculated from other fields in the schedule, specifically Formula and Percentage fields. Another type of field is Custom Field. For this one, the value for each row is computed based on the (sub)elements that are grouped on that row and can have a graphic representation when the schedule is placed on a sheet.

See Also