ScheduleFieldCreatesCircularReferences Method |
Checks whether a field ID would create a circular chain of references
when used by the PercentageOf property of this field.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool CreatesCircularReferences(
ScheduleFieldId fieldId
)
Public Function CreatesCircularReferences (
fieldId As ScheduleFieldId
) As Boolean
public:
bool CreatesCircularReferences(
ScheduleFieldId^ fieldId
)
member CreatesCircularReferences :
fieldId : ScheduleFieldId -> bool
Parameters
- fieldId ScheduleFieldId
-
The field ID to check.
Return Value
Boolean
True if the field ID would create a circular chain of references,
false otherwise.
ExceptionsException | Condition |
---|
ArgumentException |
fieldId is not InvalidScheduleFieldId or the ID of a field that can be
used to calculated percentages.
|
ArgumentNullException |
A non-optional argument was null
|
See Also