ScheduleFieldSetFormatOptions Method |
Sets the FormatOptions to optionally override the default settings in the Units class.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetFormatOptions(
FormatOptions formatOptions
)
Public Sub SetFormatOptions (
formatOptions As FormatOptions
)
public:
void SetFormatOptions(
FormatOptions^ formatOptions
)
member SetFormatOptions :
formatOptions : FormatOptions -> unit
Parameters
- formatOptions FormatOptions
-
The FormatOptions.
ExceptionsException | Condition |
---|
ArgumentException |
The display unit in formatOptions is not a valid display unit for the unit type of this ScheduleField, or the rounding method in formatOptions is not set to Nearest. See UnitUtils.IsValidDisplayUnit(UnitType, DisplayUnitType), UnitUtils.GetValidDisplayUnits(UnitType) and FormatOptions.RoundingMethod.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
See the UnitType property to determine the unit type of this field.
Example
public void FormatLengthFields(ViewSchedule schedule)
{
int nFields = schedule.Definition.GetFieldCount();
for (int n = 0; n < nFields; n++)
{
ScheduleField field = schedule.Definition.GetField(n);
if (field.GetSpecTypeId() == SpecTypeId.Length)
{
FormatOptions formatOpts = new FormatOptions();
formatOpts.UseDefault = false;
formatOpts.SetUnitTypeId(UnitTypeId.FeetFractionalInches);
field.SetFormatOptions(formatOpts);
}
}
}
Public Sub FormatLengthFields(schedule As ViewSchedule)
Dim nFields As Integer = schedule.Definition.GetFieldCount()
For n As Integer = 0 To nFields - 1
Dim field As ScheduleField = schedule.Definition.GetField(n)
If field.GetSpecTypeId().Equals(SpecTypeId.Length) Then
Dim formatOpts As New FormatOptions()
formatOpts.UseDefault = False
formatOpts.SetUnitTypeId(UnitTypeId.FeetFractionalInches)
field.SetFormatOptions(formatOpts)
End If
Next
End Sub
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also