Autodesk.Revit.DB.Architecture Namespace

 
Classes
 ClassDescription
Public classBalusterInfo The class represents an instance of a railing baluster or post.
Public classBalusterPattern Baluster pattern class.
Public classBalusterPlacement A class which contains information regarding baluster and post placement for a given railing type.
Public classBuildingPad Represents a BuildingPad element.
Public classContinuousRail Represents a continuous rail element in Autodesk Revit.
Public classContinuousRailType A type element containing the properties of a continuous rail.
Public classCutMarkType An object represents the cut mark type in Autodesk Revit.
Public classFasciaAn object that represents a fascia within the Autodesk Revit project.
Public classFasciaTypeAn object that represents the fascia type in Autodesk Revit.
Public classGutterAn object that represents a gutter within the Autodesk Revit project.
Public classGutterTypeAn object that represents the gutter type in Autodesk Revit.
Public classHandRail Represents a hand rail element in Autodesk Revit.
Public classHandRailType A rail type object that is used in the generation of hand rail.
Public classMultistoryStairs Represents a multistory stairs element in Autodesk Revit.
Public classNonContinuousRailInfo A class which contains information needed to define a single non-continuous rail in a [!:Autodesk::Revit::DB::Architecture::RailingType].
Public classNonContinuousRailStructure A class that represents a collection of Non-Continuous Rails being a part of Railing Type.
Public classPostPattern Post pattern class.
Public classRailing Represents a railing element in Autodesk Revit.
Public classCode exampleRailingType An object supporting management of baluster and post placement within the railing type.
Public classCode exampleRoomProvides access to the room topology in Autodesk Revit.
Public classCode exampleRoomFilter A filter used to match rooms.
Public classCode exampleRoomTagProvides access to the room tag in Autodesk Revit.
Public classRoomTagFilter A filter used to match room tags.
Public classRoomTagTypeAn object that represents a Room Tag type.
Public classSiteSubRegion Represents a proxy class exposing the interfaces needed to access details of a subregion.
Public classCode exampleStairs Represents a stairs element in Autodesk Revit.
Public classStairsComponentConnection Represents information about a connection among stairs components(run to landing).
Public classStairsLanding An object that represents a stairs landing in Autodesk Revit.
Public classStairsLandingType Represents a stairs landing type in Autodesk Revit.
Public classStairsPath An object that represents the stairs path.
Public classStairsPathType An object represents the stairs path type.
Public classStairsRun Represents a stairs run element in Autodesk Revit.
Public classCode exampleStairsRunType A stairs run type object that is used in the generation of stairs run.
Public classCode exampleStairsType A type element containing the properties for a component-based stair.
Public classTopographyEditScope A TopographyEditScope allows an application to create and maintain an editing session for a TopographySurface.
Public classTopographyLinkType This class represents the site file brought into the current Revit document.
Public classTopographySurface Represents a TopographySurface element.
Public classTopRail Represents a top rail element in Autodesk Revit.
Public classTopRailType A rail type object that is used in the generation of top rail.
Enumerations
 EnumerationDescription
Public enumerationBreakCornerCondition Condition on which the corner post is inserted.
Public enumerationBreakPatternCondition Condition on which patterns distribution will be broken.
Public enumerationCutLineType The available line types for a stairs cut line.
Public enumerationCutMarkSymbol The available shapes for the cut mark symbol.
Public enumerationHandRailPosition The position of the hand rail.
Public enumerationPatternJustification Justification of patterns distribution.
Public enumerationRailAngledJoinOption The angled joins of the rails.
Public enumerationRailConnectionOption The connections between rails.
Public enumerationRailExtensionStyle The extension style of the rail.
Public enumerationRailIndex The continuous rail position index.
Public enumerationRailingHeightCorrectionOption Railing height correction option.
Public enumerationRailingPathCurveJoinOption The join type of the railing path.
Public enumerationRailingPlacementPosition Railing placement position.
Public enumerationRailingSlopeOption The option determines the slope of the railing.
Public enumerationRailJoinOption The join type of the system rails.
Public enumerationRailSupportJustification The justification of the rail supports.
Public enumerationRailSupportsLayout The layout of the rail supports.
Public enumerationRailTagentJoinOption The tangent joins of the rails.
Public enumerationRailTransitionOption The transition type of the continuous rail.
Public enumerationRailTypeDefaultJoinOption The default join type of the rail.
Public enumerationRiserToTreadConnectionOption Represents the connection style of the riser and tread in relation to each other.
Public enumerationSketchedCurveSlopeOption The option determines the slop of the sketched run/landing.
Public enumerationStairsComponentConnectionEndType The end type identifying the connection type among stairs runs and landings.
Public enumerationStairsConstructionMethod Represents the construction method of the stairs.
Public enumerationStairsEndConnectionType The join style between a run and landing.
Public enumerationStairsEndNotchOption The style of notch width for the stairs.
Public enumerationStairsNumberSystemReferenceOption The reference types permitted for a number system to refer to the geometry of a stairs run.
Public enumerationStairsPathDirection The direction style of stairs path.
Public enumerationStairsPathLineShapeAtCorner The options for the line shape of a stairs path at a corner.
Public enumerationStairsRunJustification The position of the run relative to the Up-direction path used to create the run.
Public enumerationStairsRunStyle The shape of a run. Different shape has different ways of manipulation.
Public enumerationStairsSupportTopsideSurfaceType The style of the topside surface of the support.
Public enumerationStairsTextOrientation The options to be used when orienting text annotations relative to stairs.
Public enumerationStairsUndersideSurfaceStyle The style of the underside surface of the run.
Public enumerationStairsWinderStyle The calculation method for the layout of the winder run steps.
Public enumerationTreadNosingPosition Represents on which edges of the nosing to apply the nosing profile.
Public enumerationWinderPathResult Flag indicates whether curves are valid to use as base lines for winder path.