TopographyEditScope Class

A TopographyEditScope allows an application to create and maintain an editing session for a TopographySurface.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBEditScope
    Autodesk.Revit.DB.ArchitectureTopographyEditScope

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TopographyEditScope : EditScope

The TopographyEditScope type exposes the following members.

Constructors
 NameDescription
Public methodTopographyEditScope Instantiates a TopographyEditScope object.
Top
Properties
 NameDescription
Top
Methods
 NameDescription
Public methodStart Starts a topography surface edit mode for an existing TopographySurface element.
Top
Remarks
Start/end of a TopographyEditScope will start/end a transaction group. After a TopographyEditScope is started, an application can start transactions and edit the topography surface. Individual transactions the application creates inside TopographyEditScope will not appear in the undo menu. All transactions committed during the edit mode will be merged into a single one which will bear the given name passed into TopographyEditScope constructor.
See Also