StairsRunJustification Enumeration |
The position of the run relative to the Up-direction path used to create the run.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum StairsRunJustification
Public Enumeration StairsRunJustification
public enum class StairsRunJustification
type StairsRunJustification
MembersMember name | Value | Description |
---|
Left | 0 |
The creation path for the run is the left edge.
|
Center | 1 |
The creation path for the run is the center.
|
Right | 2 |
The creation path for the run is the right edge.
|
LeftExterior | 3 |
The creation path for the run is the left stringer exterior edge.
|
RightExterior | 4 |
The creation path for the run is the right stringer exterior edge.
|
See Also