WinderPathResult Enumeration |
Flag indicates whether curves are valid to use as base lines for winder path.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum WinderPathResult
Public Enumeration WinderPathResult
public enum class WinderPathResult
MembersMember name | Value | Description |
---|
Success | 0 |
Indicates curves are valid to use as path base lines for winder run.
This is only one flag indicates curves are fine to use as winder path.
|
NumberOutOfRange | 1 |
The curves number is not 2 or 3.
|
Unbound | 2 |
Curve is not bound.
|
Noncontinuous | 3 |
The curves are not continuous in one loop.
|
NotOpenLoop | 4 |
The curves are not in one open loop.
|
TooShort | 5 |
Curve length is too short.
|
ColinearOrOverlap | 6 |
Two curves are collinear or overlap.
|
SelfIntersect | 7 |
The first curve intersect with third curve.
|
InvalidCurveType | 8 |
Curve is not line.
|
NotSupported | 9 |
This path(for zigzag winder) is not supported yet
|
See Also