Room |
The RoomFilter type exposes the following members.
Name | Description | |
---|---|---|
![]() | RoomFilter | Constructs a filter which matches only rooms. |
Name | Description | |
---|---|---|
Name | Description | |
---|---|---|
// Use a RoomFilter to find all room elements in the document. It is necessary to use the RoomFilter, // and not an ElementClassFilter or the shortcut method OfClass() because the Room class is not // supported by those methods. RoomFilter filter = new RoomFilter(); // Apply the filter to the elements in the active document FilteredElementCollector collector = new FilteredElementCollector(document); IList<Element> rooms = collector.WherePasses(filter).ToElements();