StairsRunStyle Enumeration |
The shape of a run. Different shape has different ways of manipulation.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum StairsRunStyle
Public Enumeration StairsRunStyle
public enum class StairsRunStyle
MembersMember name | Value | Description |
---|
Winder | 1 |
A winder run has distorted treads, for the sake of space saving at corner.
|
Sketched | 2 |
A sketched run can have customized boundary and riser curves. User can customize stair path as well.
|
Straight | 3 |
A straight run is defined by a straight line. All treads are rectangular.
|
Spiral | 4 |
A spiral run is defined by a cylindrical helix. Both inner and outer boundaries are arcs. Risers are straight lines.
|
See Also