StructuralAsset Class

Represents the properties of a material pertinent to structural analysis.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBStructuralAsset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class StructuralAsset : IDisposable

The StructuralAsset type exposes the following members.

Constructors
 NameDescription
Public methodStructuralAsset Constructs an instance of StructuralAsset.
Top
Properties
 NameDescription
Public propertyBehavior Flag indicating whether elements of this material behave isotropically or orthotropically.
Public propertyConcreteBendingReinforcement The bending reinforcement of the asset.
Public propertyConcreteCompression The compression strength of concrete-based assets.
Public propertyConcreteShearReinforcement The shear reinforcement of the asset.
Public propertyConcreteShearStrengthReduction The shear strength reduction of the asset.
Public propertyDensity The density of the asset.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyLightweight Flag indicating whether the asset describes a material that is light-weight or not.
Public propertyMetalReductionFactor The reduction factor of the asset.
Public propertyMetalResistanceCalculationStrength The resistance calculation strength of the asset.
Public propertyMetalThermallyTreated Flag indicating whether the asset describes a material that is thermally treated or not.
Public propertyMinimumTensileStrength The minimum tensile strength of the asset.
Public propertyMinimumYieldStress The minimum yield stress of the asset.
Public propertyName The name of the structural asset.
Public propertyPoissonRatio The Poisson ratio of the asset.
Public propertyShearModulus The shear modulus of the asset.
Public propertyStructuralAssetClass The type of material that this structural asset describes (e.g. wood, concrete, metal.)
Public propertySubClass The sub-class of the asset.
Public propertyThermalExpansionCoefficient The thermal expansion coefficient of the asset.
Public propertyWoodBendingStrength The bending strength of the asset.
Public propertyWoodGrade The grade of wood used in a wood-based asset.
Public propertyWoodParallelCompressionStrength The parallel compression strength of the asset.
Public propertyWoodParallelShearStrength The parallel shear strength of the asset.
Public propertyWoodPerpendicularCompressionStrength The perpendicular compression strength of the asset.
Public propertyWoodPerpendicularShearStrength The perpendicular shear strength of the asset.
Public propertyWoodSpecies The species of wood used in a wood-based asset.
Public propertyYoungModulus The Young's modulus of the asset.
Top
Methods
 NameDescription
Public methodCopy Produces a copy of the asset.
Public methodDisposeReleases all resources used by the StructuralAsset
Public methodEquals(StructuralAsset) Determines whether this structural asset is equal to another.
Public methodSetPoissonRatio Sets the Poisson ratio of the asset.
Public methodSetShearModulus Sets the shear modulus of the asset.
Public methodSetThermalExpansionCoefficient Sets the thermal expansion coefficient of the asset.
Public methodSetYoungModulus Sets the Young's modulus of the asset.
Top
See Also