StructuralAssetSetYoungModulus Method |
Sets the Young's modulus of the asset.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetYoungModulus(
double youngModulus
)
Public Sub SetYoungModulus (
youngModulus As Double
)
public:
void SetYoungModulus(
double youngModulus
)
member SetYoungModulus :
youngModulus : float -> unit
Parameters
- youngModulus Double
-
Remarks
The Young's modulus is one-dimensional for wood-based and isotropic materials.
This method sets the x, y, and z components to the same value.
The value is in Newtons per foot meter (N/(ft · m)).
See Also