StructuralAssetMetalThermallyTreated Property |
Flag indicating whether the asset describes a material that is thermally treated or not.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool MetalThermallyTreated { get; set; }
Public Property MetalThermallyTreated As Boolean
Get
Set
public:
property bool MetalThermallyTreated {
bool get ();
void set (bool value);
}
member MetalThermallyTreated : bool with get, set
Property Value
Boolean
ExceptionsException | Condition |
---|
InapplicableDataException |
When setting this property: the material type must be Metal to set this property.
|
Remarks
Applies to Metal-based structural assets.
See Also