StructuralAssetSetShearModulus Method |
Sets the shear modulus of the asset.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetShearModulus(
double shearModulus
)
Public Sub SetShearModulus (
shearModulus As Double
)
public:
void SetShearModulus(
double shearModulus
)
member SetShearModulus :
shearModulus : float -> unit
Parameters
- shearModulus Double
-
Remarks
The shear modulus is one-dimensional for wood-based and isotropic materials.
This method sets the x, y, and z components to the same value.
The value is in Newtons per foot meter (N/(ft · m)).
See Also