StructuralAssetShearModulus Property |
The shear modulus of the asset.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic XYZ ShearModulus { get; set; }
Public Property ShearModulus As XYZ
Get
Set
public:
property XYZ^ ShearModulus {
XYZ^ get ();
void set (XYZ^ value);
}
member ShearModulus : XYZ with get, set
Property Value
XYZ
ExceptionsException | Condition |
---|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
InapplicableDataException |
When setting this property: the material type is wood.
-or-
When setting this property: the behavior is isotropic.
|
Remarks
This property cannot be used to set the shear modulus for wood-based and isotropic materials.
For such assets, use setShearModulus instead.
The value is in Newtons per foot meter (N/(ft · m)).
See Also