StructuralAssetSetThermalExpansionCoefficient Method |
Sets the thermal expansion coefficient of the asset.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetThermalExpansionCoefficient(
double thermalExpCoeff
)
Public Sub SetThermalExpansionCoefficient (
thermalExpCoeff As Double
)
public:
void SetThermalExpansionCoefficient(
double thermalExpCoeff
)
member SetThermalExpansionCoefficient :
thermalExpCoeff : float -> unit
Parameters
- thermalExpCoeff Double
-
Remarks
The thermal expansion coefficient is one-dimensional for wood-based and isotropic materials.
This method sets the x, y, and z components to the same value.
The value is in inverse Kelvin (1/K).
See Also