StructuralAssetPoissonRatio Property |
The Poisson ratio of the asset.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic XYZ PoissonRatio { get; set; }
Public Property PoissonRatio As XYZ
Get
Set
public:
property XYZ^ PoissonRatio {
XYZ^ get ();
void set (XYZ^ value);
}
member PoissonRatio : XYZ with get, set
Property Value
XYZ
ExceptionsException | Condition |
---|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
InapplicableDataException |
When setting this property: the material type is wood.
-or-
When setting this property: the behavior is isotropic.
|
Remarks
This property cannot be used to set the Poisson ratio for wood-based and isotropic materials.
For such assets, use setPoissonRatio instead.
See Also