PushButton Class

The PushButton object represents an button on a RibbonPanel.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIRibbonItem
    Autodesk.Revit.UIRibbonButton
      Autodesk.Revit.UIPushButton
        Autodesk.Revit.UIToggleButton

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PushButton : RibbonButton

The PushButton type exposes the following members.

Properties
 NameDescription
Public propertyAssemblyNameThe assembly path of the button.
Public propertyAvailabilityClassNameThe full class name for the class providing the entry point to decide availability of this push button.
Public propertyClassNameThe name of the class containing the implementation for the command.
Top
Methods
 NameDescription
Top
Remarks
Use of this class is not supported in Revit Macros.
Example
private void AddPushButton(RibbonPanel panel)
{
    PushButton pushButton = panel.AddItem(new PushButtonData("HelloWorld",
        "HelloWorld", @"D:\Sample\HelloWorld\bin\Debug\HelloWorld.dll", "HelloWorld.CsHelloWorld")) as PushButton;

    // Set ToolTip and contextual help
    pushButton.ToolTip = "Say Hello World";
    ContextualHelp contextHelp = new ContextualHelp(ContextualHelpType.Url,
        "http://www.autodesk.com");
   pushButton.SetContextualHelp(contextHelp);

    // Set the large image shown on button
    pushButton.LargeImage = 
        new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png"));
}
See Also