PushButtonClassName Property

The name of the class containing the implementation for the command.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string ClassName { get; set; }

Property Value

String
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when setting the value to .
ArgumentExceptionThrown when setting the value to an empty string.
InvalidOperationExceptionThrown when setting the value to a ToggleButton which is not initialized with an external command.
Remarks
The class name which implements the interface IExternalCommand.
See Also