RibbonItem Class

The RibbonItem object represents an item on RibbonPanel, can be a push-button or a pull-down which should contain the information for creating one RibbonItem.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIRibbonItem
    More

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RibbonItem

The RibbonItem type exposes the following members.

Properties
 NameDescription
Public propertyEnabledGets or sets a value indicating whether the item is enabled.
Public propertyItemTextGets or sets the text displayed on the item.
Public propertyItemTypeGets the item type.
Public propertyLongDescription Long description of the command tooltip
Public propertyNameThe name of the item.
Public propertyToolTipThe description that appears as a ToolTip for the item.
Public propertyToolTipImageThe image to show as a part of the button extended tooltip
Public propertyVisibleGets or sets a value indicating whether the item is visible.
Top
Methods
 NameDescription
Public methodEquals Determines whether the specified Object is equal to the current Object.
(Overrides ObjectEquals(Object))
Public methodGetContextualHelpGets the contextual help bound with this control.
Public methodSetContextualHelpSets the contextual help bound with this button.
Top
Remarks
This class is not supported in Revit Macros.
See Also
Inheritance Hierarchy