RibbonButton Class

This class is the base class of PushButton and PulldownButton.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIRibbonItem
    Autodesk.Revit.UIRibbonButton
      Autodesk.Revit.UIPulldownButton
      Autodesk.Revit.UIPushButton

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RibbonButton : RibbonItem

The RibbonButton type exposes the following members.

Properties
 NameDescription
Public propertyImageThe image of the button.
Public propertyIsEnabledByContextIndicates if this button can be executed. True if the pushbutton is permitted to be executed based on the current Revit context (active document, active view and active tool). False if the pushbutton is disabled because of the active context.
Public propertyLargeImageThe large image shown on the button.
Top
Methods
 NameDescription
Top
See Also