RibbonItemEnabled Property |
Gets or sets a value indicating whether the item is enabled.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool Enabled { get; set; }
Public Property Enabled As Boolean
Get
Set
public:
property bool Enabled {
bool get ();
void set (bool value);
}
member Enabled : bool with get, set
Property Value
Boolean
RemarksWhen the Enabled property is set to false, the item cannot be clicked,
and the item's appearance changes. The Image and Text assigned to the item appear grayed
out. For pushbuttons, the button may be enabled programmatically but be disabled in the user interface
because of the Revit context; see the property IsEnabledByContext for RibbonButton.
See Also