RibbonButtonIsEnabledByContext Property |
Indicates if this button can be executed. True if the pushbutton is permitted to be executed based on the
current Revit context (active document, active view and active tool). False if the pushbutton is disabled because
of the active context.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsEnabledByContext { get; }
Public ReadOnly Property IsEnabledByContext As Boolean
Get
public:
property bool IsEnabledByContext {
bool get ();
}
member IsEnabledByContext : bool with get
Property Value
Boolean
RemarksThe button may be enabled for a given context but still disabled programmatically using the Enabled property
for the button.
See Also