UIControlledApplication Class

Represents the Autodesk Revit user interface, providing access to UI customization methods and events.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIUIControlledApplication

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class UIControlledApplication

The UIControlledApplication type exposes the following members.

Properties
 NameDescription
Public propertyActiveAddInId Get current active external application or external command id.
Public propertyControlledApplicationReturns the database level ControlledApplication represented by this UI-level ControlledApplication.
Public propertyIsLateAddinLoading Indicates whether this add-in is loaded on the fly or not. If it is loaded when Revit is starting up, it is false, otherwise it should be true.
Public propertyIsViewerModeActive Determines if Revit session is in Viewer mode.
Public propertyLoadedApplications Returns an array of successfully loaded external applications.
Public propertyMainWindowHandleGet the handle of the Revit main window.
Public propertyProductIsRS Identifies if the current Revit product has an RS designation. Most add-ins will not need to use this information.
Top
Methods
 NameDescription
Public methodCreateAddInCommandBindingCreates a new AddInCommandBinding.
Public methodCode exampleCreateRibbonPanel(String) Create a new RibbonPanel on the Add-Ins tab.
Public methodCreateRibbonPanel(String, String) Create a new RibbonPanel on the specified tab.
Public methodCreateRibbonPanel(Tab, String) Create a new RibbonPanel on the designated standard Revit tab.
Public methodCode exampleCreateRibbonTab Creates a new tab on the Revit user interface.
Public methodGetDockablePaneGets a DockablePane object by its ID.
Public methodGetRibbonPanels Get all the custom Panels on Add-Ins tab of Revit.
Public methodGetRibbonPanels(String) Get all the custom Panels on a designated Revit tab.
Public methodGetRibbonPanels(Tab) Get all the custom Panels on a designated standard Revit tab.
Public methodLoadAddInLoads add-ins from the given manifest file.
Public methodLoadPackageContentsLoads add-ins from the given packageContents.xml file.
Public methodRegisterContextMenuAdds a new context menu creator.
Public methodCode exampleRegisterDockablePaneAdds a new dockable pane to the Revit user interface.
Public methodRemoveAddInCommandBindingRemoves an AddInCommandBinding.
Top
Events
 NameDescription
Public eventApplicationClosing Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
Public eventCode exampleDialogBoxShowing Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
Public eventDisplayingOptionsDialog Subscribe to the options dialog displaying event to be notified when Revit options dialog is displaying.
Public eventDockableFrameFocusChanged Subscribe to this event to be notified when a Revit GenericDockableFrame has gained focus or lost focus in the Revit user interface. This event is called only for API-created GenericDockableFrames.
Public eventDockableFrameVisibilityChanged Subscribe to this event to be notified when a Revit GenericDockableFrame has been shown or hidden in the Revit user interface. This event is called only for API-created GenericDockableFrames.
Public eventFabricationPartBrowserChanged Subscribe to MEP Fabrication part browser changed event to be notified when MEP Fabrication part browser is updated.
Public eventFormulaEditing Subscribe to the FormulaEditing event to be notified when the edit formula button has been clicked.
Public eventCode exampleIdling Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.
Public eventSelectionChanged Subscribe to the SelectionChanged event to be notified after the selection was changed.
Public eventThemeChanged Subscribe to the ThemeChanged event to be notified after the theme was changed.
Public eventTransferredProjectStandards Subscribe to the TransferredProjectStandards event to be notified after the scope of a Transfer Project Standards operation has been finalized.
Public eventTransferringProjectStandards Subscribe to the TransferringProjectStandards event to be notified before the scope of an impending Transfer Project Standards operation has been finalized in the Transfer Project Standards dialog.
Public eventViewActivated Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
Public eventViewActivating Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.
Top
Remarks
This class does not provide access to documents because it is provided to you through the ExternalApplication OnStartup()/OnShutdown() methods, and those methods are when it is not possible to work with Revit documents. You can work with documents by getting them from the UIApplication class; that class is obtained from events and ExternalCommand callbacks.
See Also