UIControlledApplicationTransferringProjectStandards Event |
Subscribe to the TransferringProjectStandards event to be notified before the scope of an impending Transfer Project Standards operation has been finalized in the Transfer Project Standards dialog.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic event EventHandler<TransferringProjectStandardsEventArgs> TransferringProjectStandards
Public Event TransferringProjectStandards As EventHandler(Of TransferringProjectStandardsEventArgs)
public:
event EventHandler<TransferringProjectStandardsEventArgs^>^ TransferringProjectStandards {
void add (EventHandler<TransferringProjectStandardsEventArgs^>^ value);
void remove (EventHandler<TransferringProjectStandardsEventArgs^>^ value);
}
member TransferringProjectStandards : IEvent<EventHandler<TransferringProjectStandardsEventArgs>,
TransferringProjectStandardsEventArgs>
Value
EventHandlerTransferringProjectStandardsEventArgs
RemarksThis event allows an external application to add additional items to the possible list of items to be transferred.
These items will be visible and selectable in the Transfer Project Standards dialog box. By default, new items added in this manner will be enabled for transfer.
During the scope of this event, modification is not permitted to either the source or target documents. And this event is not cancellable.
See Also