UIControlledApplicationGetDockablePane Method |
Gets a DockablePane object by its ID.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic DockablePane GetDockablePane(
DockablePaneId id
)
Public Function GetDockablePane (
id As DockablePaneId
) As DockablePane
public:
DockablePane^ GetDockablePane(
DockablePaneId^ id
)
member GetDockablePane :
id : DockablePaneId -> DockablePane
Parameters
- id DockablePaneId
- Unique identifier for the new pane.
Return Value
DockablePane
ExceptionsException | Condition |
---|
ArgumentException | Thrown if no dockable pane has been registered with identifier %id%. |
ArgumentException | Thrown if the dockable pane with identifier %id% has not been created yet. |
See Also