UIControlledApplicationCreateRibbonPanel(String, String) Method |
Create a new RibbonPanel on the specified tab.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic virtual RibbonPanel CreateRibbonPanel(
string tabName,
string panelName
)
Public Overridable Function CreateRibbonPanel (
tabName As String,
panelName As String
) As RibbonPanel
public:
virtual RibbonPanel^ CreateRibbonPanel(
String^ tabName,
String^ panelName
)
abstract CreateRibbonPanel :
tabName : string *
panelName : string -> RibbonPanel
override CreateRibbonPanel :
tabName : string *
panelName : string -> RibbonPanel
Parameters
- tabName String
- The name of the tab, on which the new panel will be created.
- panelName String
- The name of the panel to be created.
Return Value
RibbonPanel
Exceptions
Remarks This method will create a custom panel appending to the specified tab. This method is not supported in Macros.
See Also