UIControlledApplicationApplicationClosing Event |
Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic event EventHandler<ApplicationClosingEventArgs> ApplicationClosing
Public Event ApplicationClosing As EventHandler(Of ApplicationClosingEventArgs)
public:
event EventHandler<ApplicationClosingEventArgs^>^ ApplicationClosing {
void add (EventHandler<ApplicationClosingEventArgs^>^ value);
void remove (EventHandler<ApplicationClosingEventArgs^>^ value);
}
member ApplicationClosing : IEvent<EventHandler<ApplicationClosingEventArgs>,
ApplicationClosingEventArgs>
Value
EventHandlerApplicationClosingEventArgs
RemarksThis event is raised when the Revit application is just about to be closed.
Event is not cancellable. The 'Cancellable' property of event's argument is always False.
No document may be modified at the time of the event.
The sender object of this event is UIControlledApplication object.
See Also