UIControlledApplicationGetRibbonPanels(String) Method |
Get all the custom Panels on a designated Revit tab.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic virtual List<RibbonPanel> GetRibbonPanels(
string tabName
)
Public Overridable Function GetRibbonPanels (
tabName As String
) As List(Of RibbonPanel)
public:
virtual List<RibbonPanel^>^ GetRibbonPanels(
String^ tabName
)
abstract GetRibbonPanels :
tabName : string -> List<RibbonPanel>
override GetRibbonPanels :
tabName : string -> List<RibbonPanel>
Parameters
- tabName String
- The name of the tab on which the panels are located.
Return Value
ListRibbonPanel
Remarks Built-in panels will not be included. tabName must be the name of one of the tabs added
by
CreateRibbonTab(String).
This method is not supported in Macros.
See Also