UIControlledApplicationCreateRibbonTab Method |
Creates a new tab on the Revit user interface.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic virtual void CreateRibbonTab(
string tabName
)
Public Overridable Sub CreateRibbonTab (
tabName As String
)
public:
virtual void CreateRibbonTab(
String^ tabName
)
abstract CreateRibbonTab :
tabName : string -> unit
override CreateRibbonTab :
tabName : string -> unit
Parameters
- tabName String
- The name of the tab to be created.
Exceptions
Remarks This method will create a custom tab at the end of the list of static tabs. If multiple tabs are added, they will be shown in the order added. This method is not supported in Macros.
Examplepublic Result OnStartup(UIControlledApplication application)
{
String tabName = "This Tab Name";
application.CreateRibbonTab(tabName);
PushButtonData button1 = new PushButtonData("Button1", "My Button #1",
@"C:\ExternalCommands.dll", "Revit.Test.Command1");
PushButtonData button2 = new PushButtonData("Button2", "My Button #2",
@"C:\ExternalCommands.dll", "Revit.Test.Command2");
RibbonPanel m_projectPanel = application.CreateRibbonPanel(tabName, "This Panel Name");
List<RibbonItem> projectButtons = new List<RibbonItem>();
projectButtons.AddRange(m_projectPanel.AddStackedItems(button1, button2));
return Result.Succeeded;
}
Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
Dim tabName As [String] = "This Tab Name"
application.CreateRibbonTab(tabName)
Dim button1 As New PushButtonData("Button1", "My Button #1", "C:\ExternalCommands.dll", "Revit.Test.Command1")
Dim button2 As New PushButtonData("Button2", "My Button #2", "C:\ExternalCommands.dll", "Revit.Test.Command2")
Dim m_projectPanel As RibbonPanel = application.CreateRibbonPanel(tabName, "This Panel Name")
Dim projectButtons As New List(Of RibbonItem)()
projectButtons.AddRange(m_projectPanel.AddStackedItems(button1, button2))
Return Result.Succeeded
End Function
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also