UIControlledApplicationGetRibbonPanels Method |
Get all the custom Panels on Add-Ins tab of Revit.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic virtual List<RibbonPanel> GetRibbonPanels()
Public Overridable Function GetRibbonPanels As List(Of RibbonPanel)
public:
virtual List<RibbonPanel^>^ GetRibbonPanels()
abstract GetRibbonPanels : unit -> List<RibbonPanel>
override GetRibbonPanels : unit -> List<RibbonPanel>
Return Value
ListRibbonPanel
Remarks The built-in panels won't be included and the panels added to tabs other than Add-Ins will not be included.
This method is not supported in Macros.
See Also