UIControlledApplicationCreateRibbonPanel(Tab, String) Method |
Create a new RibbonPanel on the designated standard Revit tab.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic virtual RibbonPanel CreateRibbonPanel(
Tab tab,
string panelName
)
Public Overridable Function CreateRibbonPanel (
tab As Tab,
panelName As String
) As RibbonPanel
public:
virtual RibbonPanel^ CreateRibbonPanel(
Tab tab,
String^ panelName
)
abstract CreateRibbonPanel :
tab : Tab *
panelName : string -> RibbonPanel
override CreateRibbonPanel :
tab : Tab *
panelName : string -> RibbonPanel
Parameters
- tab Tab
- The target tab, on which the new panel will be created.
- panelName String
- The name of the panel to be created.
Return Value
RibbonPanel
Exceptions
Remarks This method will create a custom panel appending to the specified tab. This method is not supported in Macros.
See Also