WallSweepInfo Class

Represents a wall sweep or reveal of a vertically compound structure.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBWallSweepInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class WallSweepInfo : IDisposable

The WallSweepInfo type exposes the following members.

Constructors
 NameDescription
Public methodWallSweepInfo(Boolean, WallSweepType) Constructs a new WallSweepInfo instance.
Public methodWallSweepInfo(WallSweepType, Boolean) Constructs a new WallSweepInfo instance.
Top
Properties
 NameDescription
Public propertyCutsWall Indicates if you want the sweep to cut geometry out of the host wall.
Public propertyDefaultSetback The sweep setback distance from inserts, such as windows and doors.
Public propertyDistance Represents the distance from either the top or base of the wall for horizontal sweeps, or the parameter along the wall's path curve for vertical ones.
Public propertyDistanceMeasuredFrom Indicates if Distance is measured from the top or bottom of the wall.
Public propertyId The id of the sweep or reveal.
Public propertyIsCutByInserts Indicates if the sweep is cut by wall inserts.
Public propertyIsFixed Indicates if the described wall sweep is fixed. A sweep is fixed if it is a part of a vertical compound structure.
Public propertyIsProfileFlipped Indicates if the profile is applied upside-down.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyIsVertical Indicates whether the sweep or reveal is swept vertically or horizontally.
Public propertyMaterialId The element id of the material used to create the sweep or reveal.
Public propertyProfileId The element id of the profile family used to create the sweep or reveal.
Public propertyWallOffset The offset from the sweep or reveal to the wall.
Public propertyWallSide The side of the wall to which the sweep or reveal is attached.
Public propertyWallSweepOrientation Indicates how the profile of a horiztonal sweep is oriented with repect to the wall side face.
Public propertyWallSweepType The type (either a wall sweep or a reveal).
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the WallSweepInfo
Public methodIsEqual Determines if the input object is equivalent to this WallSweepInfo.
Top
See Also