PulldownButton Class

The PulldownButton object represents a button with a drop-down list on RibbonPanel.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIRibbonItem
    Autodesk.Revit.UIRibbonButton
      Autodesk.Revit.UIPulldownButton
        Autodesk.Revit.UISplitButton

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PulldownButton : RibbonButton

The PulldownButton type exposes the following members.

Properties
 NameDescription
Top
Methods
 NameDescription
Public methodAddPushButtonAdds a new pushbutton to the pulldown button and associates it with an ExternalCommand.
Public methodAddSeparatorAdds a separator to the drop-down list.
Public methodGetItemsGets a copy of the collection of buttons assigned to the pulldown button.
Top
Remarks
Use of this class is not supported in Revit Macros.
See Also