PartUtils Class

General Part utility methods
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBPartUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class PartUtils

The PartUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberAreElementsValidForCreateParts Identifies if the given elements can be used to create parts.
Public methodStatic memberArePartsValidForDivide Identifies if provided members are valid for dividing parts.
Public methodStatic memberArePartsValidForMerge Identifies whether Part elements may be merged.
Public methodStatic memberCreateMergedPart Create a single merged part which represents the Parts specified by partsToMerge.
Public methodStatic memberCreateParts(Document, ICollectionElementId) Creates a new set of parts out of the original elements.
Public methodStatic memberCreateParts(Document, ICollectionLinkElementId) Creates a new set of parts out of the original elements.
Public methodStatic memberDivideParts Creates divided parts out of parts.
Public methodStatic memberFindMergeableClusters Segregates a set of elements into subsets which are valid for merge.
Public methodStatic memberGetAssociatedPartMaker(Document, ElementId) Gets associated PartMaker for an element.
Public methodStatic memberGetAssociatedPartMaker(Document, LinkElementId) Gets associated PartMaker for an element.
Public methodStatic memberGetAssociatedParts(Document, ElementId, Boolean, Boolean) Returns all Parts that are associated with the given element.
Public methodStatic memberGetAssociatedParts(Document, LinkElementId, Boolean, Boolean) Returns all Parts that are associated with the given element
Public methodStatic memberGetChainLengthToOriginal Calculates the length of the longest chain of divisions/merges to reach to an original non-Part element that is the source of the tested part.
Public methodStatic memberGetMergedParts Retrieves the element ids of the source elements of a merged part.
Public methodStatic memberGetPartMakerMethodToDivideVolumeFW Obtains the object allowing access to the divided volume properties of the PartMaker.
Public methodStatic memberCode exampleGetSplittingCurves(Document, ElementId) Identifies the curves that were used to create the part.
Public methodStatic memberCode exampleGetSplittingCurves(Document, ElementId, Plane) Identifies the curves that were used to create the part and the plane in which they reside.
Public methodStatic memberCode exampleGetSplittingElements Identifies the elements ( reference planes, levels, grids ) that were used to create the part.
Public methodStatic memberHasAssociatedParts(Document, ElementId) Checks if an element has associated parts.
Public methodStatic memberHasAssociatedParts(Document, LinkElementId) Checks if an element has associated parts.
Public methodStatic memberIsMergedPart Is the Part the result of a merge.
Public methodStatic memberIsPartDerivedFromLink Is the Part derived from link geometry.
Public methodStatic memberIsValidForCreateParts Identifies if the given element can be used to create parts.
Top
See Also