PartUtilsGetChainLengthToOriginal Method |
Calculates the length of the longest chain of divisions/merges to reach to an original non-Part element that is the source of the tested part.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static int GetChainLengthToOriginal(
Part part
)
Public Shared Function GetChainLengthToOriginal (
part As Part
) As Integer
public:
static int GetChainLengthToOriginal(
Part^ part
)
static member GetChainLengthToOriginal :
part : Part -> int
Parameters
- part Part
-
The part to be tested
Return Value
Int32
The length of the longest chain.
Exceptions
See Also