PartUtilsGetSplittingElements Method

Identifies the elements ( reference planes, levels, grids ) that were used to create the part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ISet<ElementId> GetSplittingElements(
	Document document,
	ElementId partId
)

Parameters

document  Document
The source document of the part.
partId  ElementId
The part id.

Return Value

ISetElementId
The elements that created the part. Empty if partId is not a Part or Part is not divided.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
Example
public void GetElementDividers(Part part)
{
   StringBuilder message = new StringBuilder();

   // Get Element dividers.
   ISet<ElementId> divisionElements = PartUtils.GetSplittingElements(part.Document, part.Id);

   if (divisionElements.Count == 0)
      message.AppendLine("Part is not divided.");
   else
   {
      message.AppendLine("The dividers are : ");
      foreach (var reference in divisionElements)
      {
         Element element = part.Document.GetElement(reference);
         message.AppendLine(element.GetType().Name + " " + element.Id.ToString() + " ");
      }
   }

   TaskDialog.Show("Revit", message.ToString());
}
See Also