PartUtilsCreateParts(Document, ICollectionLinkElementId) Method |
Creates a new set of parts out of the original elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void CreateParts(
Document document,
ICollection<LinkElementId> hostOrLinkElementIds
)
Public Shared Sub CreateParts (
document As Document,
hostOrLinkElementIds As ICollection(Of LinkElementId)
)
public:
static void CreateParts(
Document^ document,
ICollection<LinkElementId^>^ hostOrLinkElementIds
)
static member CreateParts :
document : Document *
hostOrLinkElementIds : ICollection<LinkElementId> -> unit
Parameters
- document Document
-
The document containing the elements.
- hostOrLinkElementIds ICollectionLinkElementId
-
The elements that parts will be created from.
ExceptionsException | Condition |
---|
ArgumentException |
One or more element ids was not permitted for creating parts.
HostOrLinkElements should be of a valid category and the ids should be valid and should not already be divided into parts.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
Remarks
Parts will be added to the model after regeneration.
To get the ids of the parts created by this method use PartUtils.GetAssociatedParts() with the contents of hostOrLinkElementIds.
See Also