PartUtilsHasAssociatedParts(Document, ElementId) Method |
Checks if an element has associated parts.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool HasAssociatedParts(
Document hostDocument,
ElementId elementId
)
Public Shared Function HasAssociatedParts (
hostDocument As Document,
elementId As ElementId
) As Boolean
public:
static bool HasAssociatedParts(
Document^ hostDocument,
ElementId^ elementId
)
static member HasAssociatedParts :
hostDocument : Document *
elementId : ElementId -> bool
Parameters
- hostDocument Document
-
The document.
- elementId ElementId
-
The element to be checked for associated Parts
Return Value
Boolean
True if the element has associated Parts.
Exceptions
See Also