PartUtilsFindMergeableClusters Method |
Segregates a set of elements into subsets which are
valid for merge.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<ICollection<ElementId>> FindMergeableClusters(
Document doc,
ICollection<ElementId> partIds
)
Public Shared Function FindMergeableClusters (
doc As Document,
partIds As ICollection(Of ElementId)
) As IList(Of ICollection(Of ElementId))
public:
static IList<ICollection<ElementId^>^>^ FindMergeableClusters(
Document^ doc,
ICollection<ElementId^>^ partIds
)
static member FindMergeableClusters :
doc : Document *
partIds : ICollection<ElementId> -> IList<ICollection<ElementId>>
Parameters
- doc Document
-
The document.
- partIds ICollectionElementId
-
A set of element ids.
Return Value
IListICollectionElementId
An array of clusters such that all the elements in a single cluster
are valid for merge. Each cluster will be maximal in that appending
any of the other Parts specified as input will result in a collection
that is not valid for merge.
Exceptions
Remarks
Element ids in the input set that do not correspond to Part
elements will be ignored, as will element ids corresponding
to Part elements that already have associated parts.
See Also