PartUtilsCreateParts(Document, ICollectionElementId) Method |
Creates a new set of parts out of the original elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void CreateParts(
Document document,
ICollection<ElementId> elementIds
)
Public Shared Sub CreateParts (
document As Document,
elementIds As ICollection(Of ElementId)
)
public:
static void CreateParts(
Document^ document,
ICollection<ElementId^>^ elementIds
)
static member CreateParts :
document : Document *
elementIds : ICollection<ElementId> -> unit
Parameters
- document Document
-
The document containing the elements.
- elementIds ICollectionElementId
-
The elements that parts will be created from.
ExceptionsException | Condition |
---|
ArgumentException |
One or more element ids was not permitted for creating parts.
Elements should be of a valid category and the ids should be valid and should not already be divided into parts.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
Remarks
Parts will be added to the model after regeneration.
See Also