PartUtilsGetAssociatedPartMaker(Document, LinkElementId) Method |
Gets associated PartMaker for an element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static PartMaker GetAssociatedPartMaker(
Document hostDocument,
LinkElementId hostOrLinkElementId
)
Public Shared Function GetAssociatedPartMaker (
hostDocument As Document,
hostOrLinkElementId As LinkElementId
) As PartMaker
public:
static PartMaker^ GetAssociatedPartMaker(
Document^ hostDocument,
LinkElementId^ hostOrLinkElementId
)
static member GetAssociatedPartMaker :
hostDocument : Document *
hostOrLinkElementId : LinkElementId -> PartMaker
Parameters
- hostDocument Document
-
The document
- hostOrLinkElementId LinkElementId
-
The id for the element to be checked for associated Parts
Return Value
PartMaker
The PartMaker element that is making Parts for this element.
if there is no associated PartMaker.
Exceptions
See Also