BaseImportOptions Class

A base class containing import options used during import of several formats.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBaseImportOptions
    More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class BaseImportOptions : IDisposable

The BaseImportOptions type exposes the following members.

Properties
 NameDescription
Public propertyAutoCorrectAlmostVHLines Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines.
Public propertyColorMode Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors.
Public propertyCustomScale Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyOrientToView Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false)
Public propertyPlacement Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates.
Public propertyReferencePoint The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin.
Public propertyThisViewOnly Imports drawings into the view that was passed into the import method. This option is not available in 3D views.
Public propertyUnit The unit of measure for imported geometry.
Public propertyVisibleLayersOnly Only import the visible layers.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the BaseImportOptions
Public methodGetDefaultLengthUnit Get the default length unit used for importing unitless files.
Public methodGetLayerSelection Get all set layers name which user want to import into Revit.
Public methodSetDefaultLengthUnit Set the default length unit used for importing unitless files.
Public methodSetLayerSelection Set the layers name which user want to import into Revit.
Top
See Also
Inheritance Hierarchy